Error when creating Microsoft tenant

Minor incident Marketplace instances Finland France USA Brazil Germany Switzerland
2024-07-30 15:22 CEST · 1 hour, 13 minutes

Updates

Resolved

Please be informed that this incident has now been resolved.

July 30, 2024 · 16:35 CEST
Issue

We are currently aware of the error message that appears when creating Microsoft tenant, we are working with Microsoft to resolve this issue.
As soon as we have more updates, we will update you

July 30, 2024 · 15:22 CEST

← Back