Problem with new NCE orders

Minor incident Marketplace instances Finland France USA Brazil Germany Switzerland
2024-08-01 15:57 CEST · 4 days, 19 hours, 10 minutes

Updates

Resolved

This issue has now been resolved, thank you for your patience.

August 6, 2024 · 11:07 CEST
Issue

We are currently aware that there is a problem with new NCE orders, quantity changes and renewals, as they take long time to complete.

Microsoft is currently looking into this problem, we will keep you updated.

August 1, 2024 · 15:57 CEST

← Back