HelpDesk Currently Unavailable

Minor incident Support Portal Helpdesk Jira
2024-10-02 10:56 CEST · 3 minutes

Updates

Resolved

Please be informed, our helpdesk is back online and the issue has been resolved.

October 2, 2024 · 10:59 CEST
Investigating

Our helpdesk is currently not available due to technical problems. We are working with highest priority to find a solution. In the meantime, we thank you for your patience.

October 2, 2024 · 10:56 CEST

← Back