Billing Preview delayed from 27.03 on Finland Instance

Minor incident Marketplace instances Finland
2025-03-28 08:39 CET · 7 hours, 20 minutes

Updates

Resolved

Billing Preview data updated

March 28, 2025 · 15:58 CET
Issue

Billing Preview on the Finland instance has not been updated since March 27. Our team is actively working on resolving, the data is expected to be up to data at mid-day.

March 28, 2025 · 08:39 CET

← Back